Page 1 of 1

Thanks for this port!

Posted: Thu Jan 26, 2017 2:44 pm
by VGA
Thanks for the work you put into this port, I like this kind of aesthetics, meta-nostalgic as you put it. I have a couple of annoyances to report, please note that I am a noob in Quake but very experienced in using source ports, especially for Doom.

1) The console font is way too small, how can I increase it? I am playing on 1680x1050 resolution

2) I can't see any decals, with the basic hitscan weapons at least. Shouldn't there be bullet marks on the wall, like in ZDoom?

3) Sometimes I see this error in the console "Unkown command -mlook". It may have to do with alt-tabbing.

4) Is it normal that I can look around while the console is down? It's just weird because the gameplay is paused.

Re: Thanks for this port!

Posted: Thu Jan 26, 2017 2:50 pm
by VGA
Double post because this is very important. For setting up S8 I extracted it in a new folder then copied the two pak files from my Quake GOG installation to the id1 folder. Also I run a tool that extracted the songs from the GOG CD image files and put them inside a folder named MUSIC inside id1. And I ran vispatch to get the transparent liquids, although I don't like how they look, it's like very transparent liquid with a semi-opaque surface on it, instead of looking like a thick liquid.

Music seems to be working but after about a minute of gameplay an annoying chirping sound starts. If I reduce the music it also is affected, so I think the music playback is getting corrupted? Happens on e1m1 and e2m1.

Re: Thanks for this port!

Posted: Sat Jan 28, 2017 12:36 pm
by func_qbism
1. Yeah... console text doesn't scale.
2. 'r_stains 1' in console will turn on stainmaps.
3. That command is from original Quake and has been removed. You can google what it does.
4. If 'normal' is original quake.exe on a vintage Pentium, no.

Liquid- what happens when you change the alpha cvars? See the console commands post for a list.

Music- I haven't heard of that bug. Might try changing _snd_mixahead up or down, or fiddle with song extraction settings?