enable hibernate on Linux Mint 19, or "brick ur install newb"

Post Reply
User avatar
func_qbism
Posts: 76
Joined: Tue Aug 04, 2015 1:51 pm
Contact:

enable hibernate on Linux Mint 19, or "brick ur install newb"

Post by func_qbism » Thu Sep 20, 2018 11:28 pm

Sharing notes-to-self below. I'm no expert so I followed instructions by others. I like to leave lots of stuff open and I like the hibernate option. Still, I usually save everything to be safe. Sometimes hibernate does not work. Apparently it was unstable enough to remove as a default from Ubuntu 18 and hence Mint 19.

Every step is a chance to break your install. Please double-check with primary references before proceeding, such as-
http://www.linuxandubuntu.com/home/how- ... untu-linux
https://github.com/linuxmint/Cinnamon/issues/7660

0. Not sure if required, (especially depending on when you're reading this vs. time of writing) but maybe update from 4.15 kernel to 4.18 per https://forums.linuxmint.com/viewtopic. ... 6#p1525706

1. Ensure swap is larger than RAM. One way is to check System Monitor -> Resources. Otherwise try gparted from Live CD or USB to resize.

2. Sudo create /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

Code: Select all

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes
3. Add resume=UUID=<yourswapuuid> to /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT. Example:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=efc2df01-c6a0-45a9-bd68-c0469851bf0f"
4. sudo update-grub

5. reboot

6. Should now be able to select "hibernate" from shutdown screen. Unless you just bricked yourself.
Welcome to Rivendale, Mister Anderson.

Post Reply